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C H A P T E R

10 Using the 824 Utility Software 

The 824 Utility software is a powerful tool for use with the
System 824 from Larson Davis. This software will allow
you to control, setup, download and translate your 824
measurement data quickly and easily.

The 824 Utility program has three sections that perform the
functions on the 824. 

• The setup section provides support for creating, editing,
storing and retrieving setups from the 824 and from files.

• The download section provides a means by which to
retrieve the measurement data from the 824.

• The translate section provides support for translating the
downloaded measurement data, and displaying or print-
ing it in a text format, or exporting the measurement data
to a spreadsheet program.

In this chapter we will discuss installing the software, get-
ting the software started on your computer, connecting the
824 to the serial port of your computer, explain the Main
Screen Toolbar functions, and then go onto discuss each of
the three functions of the software in greater depth.

824 Utility Installation

To install the 824 Utility software package place the disk
(CD) into your CD-ROM drive. From Windows 95 press



10-2 824 Reference Manual 9/29/09

START and then select the RUN menu item. A prompt will
appear to enter the program name. Enter “E:\824auto.exe”. 

A new screen will appear with several menu items to choose
from.

Select “Install Software” from the menu items. Another
screen will appear with several more choices. Select
“INSTALL 824 Utility Software”. The 824 utility software
will automatically begin the installation process. The
installer program will prompt you through the installation. A
message will appear indicating that the software was suc-
cessfully installed.

Starting the 824 Utility Software

To start the 824 Utility software in Windows �• , press
START and then select the Programs/Larson Davis/824Util
menu item.

Connecting to Your Computer

To connect the 824 to a computer, use the CBL006 cable
included with your System 824. The round 8-pin connector
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plugs into the Serial port of the 824 and the 9-pin connector
plugs into a serial port on your computer. 

You do not need to be connected to
the 824 in order to translate files
which have already been
downloaded.

Before any functions can be performed on the 824, you must
connect the 824 to the 824 Utility software. To connect to
the 824:

Step 1 Attach the CBL006 to the 824 and to the serial 
port on the computer as described earlier.

Step 2 Start the 824 Utility program.

NOTE: The 824 will power on when it
senses anything on the serial connector.
You may notice the 824 powering on
automatically before you press the power
button.

Step 3 Power on the 824. 

Step 4 Press the Connect button on the tool bar.

Step 5 The connect dialog box will appear.
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NOTE: See "Communication" on page 3-
34 for details on changing the
communication parameters on the 824.

Step 6 Select the comport that your 824 is connected to, 
select the baud rate, and press the connect button.

After a successful connection, the setup window will appear
with a system setup in the setup list box. The 824’s serial
number and title will be displayed on the setup dialog box
screen.

824 Utility Tool Bar

The tool bar for the 824 Utility program provides support for
the main functions of the 824 Utility program. All Toolbar
functions can also be performed from the pull down menus
at the top of the 824 Utility Software screen.
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Connect button. This button is used to 
establish a connection to the 824. Pressing this 
button will bring up the connect dialog box 
where the connection parameters can be 
defined.

Retrieve Setups from 824. This button will 
retrieve all current setups in the 824.

Create new setup button. This button will 
allow the user to create a new setup that can 
then be saved to disk, or saved in the 824.

Open a setup from a computer file. This button 
will allow the user to retrieve previously stored 
setup files. 

Store setup to disk. This button will allow the 
user to store a setup to a disk. 

Store setup in 824. This button will store the 
setup in the 824. This function must be 
performed before the setup can be used inside 
the 824.

Setup window button. This button will activate 
the setup window portion of the 824 Utility 
Program
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824 Utility Setup Window

The setup window is the default window that will open up
when the 824 Utility program is started. The setup window
will allow you to edit existing setups, retrieve setups from
the 824 or a file, create new setups, and store setups to the
824 or to a file.

The main setup window has 2 sections: the setup list box,
and the settings dialog section. The setup list box will list all
setups that have either been created or retrieved from the

Download window button. This button will 
open the download section of the 824 Utility 
program.

Translate window button. This button will 
open the translate section of the program. It 
will provide a file tree where the contents of 
the downloaded measurement files can be 
viewed.

Export measurement button. Exports the 
currently selected measurement file to a user 
defined spreadsheet program. This button will 
only be active when you are in the translate 
section of the program, and there is a 
measurement file being displayed.
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824 or a disk file. The settings dialog section will allow you
to manipulate the setup.

Retrieving setups from the 824

Setups stored in the 824 can be retrieved by clicking on the
Get Setup button on the tool bar or by selecting Get Setups
From 824 from the File Menu. 

Setup List Box

Settings Tab Dialog 
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Setups will be retrieved from the 824 and will be displayed
in the Setup listbox. 

In the list of setup files, the system setup is the first setup
and is followed by all of the permanent and user-defined set-
ups. In the setup list box, there are several parts of the Setup
title that can be used to identify the setup type.

Highlighting one of the setups in the list displays all of the
available settings in the setup dialog box (right side of the

The three letter Larson Davis assigned
name is listed in the blue Ovals. This
indicates the type of instrument ID for
which the setup was created.

‘P’ stands for a permanent ID. This would be
an original setup defined at Larson Davis
and cannot be modified.

No letter or an arrow indicates a modifiable User defined ID.

A lock icon in this place indicates a
user ID that has been locked so it can-
not be modified.

The name of the ID is listed in the right hand column.
For the permanent ID’s, this will be the Larson Davis
instrument type. For a user defined ID, this can be any-
thing that the user defines.
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window). The setups are organized and grouped similar to
the 824 menu structure in the instrument. Click on the differ-
ent tabs to access all of the setup parameters.

Modifying and Stori ng Setups to the 824

NOTE: If you change settings in the
Utility program to an active setup in the
824, those changes will not take effect in
the 82 unless the modified setup is re-
selected.

With the 824 Utility software you can make modifications to
any of the user defined setups and the system setup. For
example, in the System setup, you can change any of the
parameters for the Title, Calibration, Power, Date/Time,
Controls or Modem and then send the modified setup to the
824. To store the modified setup, select the Save Setup to
824 menu item from the File menu or click on the Store
Setup in 824 button on the tool bar. 

Changing System Settings The system selection on the setup list box contains the gen-
eral settings for the 824. The selections here include, Title,
Options*, Calibration, Power, Date and Time, Controls and
Modem. To change one of these settings, click on the appro-
priate tab, and enter the changes.

Select different tabs to access 
all of the setup functions.

Parameters can be entered manually, 
or the pull down selections can be 
used.

*The Option Settings show what
options were purchased for this
instrument and can’t be changed. To
purchase an option, contact your
Larson Davis representative.
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Manipulating a Setup To change any of the variables for a particular user defined
setup, select the setup. The appropriate setup tab dialog will
appear at the right of the setup list box. Select the setting you
wish to change and enter the new value.



9/29/09 Using the 824 Utility Software 10-11

You can also access several setup functions by right clicking
on the Setup in the Setup list box.

The following functions can be accessed by pressing the
right mouse button while within the Setup list box. The
Setup Menu items will appear enabled or disabled depend-
ing on the setup selected. For example, it is not possible to
delete a permanent 824 setup, so the Delete Setup menu
item will be disabled if a permanent 824 setup is selected.

The Rename Setup button allows you to 
rename the selected user defined setup.

The Make Setup Current button will cause the 
selected setup to become the Active setup in 
the 824.

The Lock Setup button will write-protect the 
selected setup in the 824. 

The Unlock Setup button will write-enable the 
selected setup in the 824.

The Delete setup button will delete the selected 
user defined setup from the 824.
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Saving Setups to Disk Files

Once you have created or modified a setup, you can store the
setup to a file. Select the Save Setup to a File menu item
from the File menu or click on the Save to File button on the
tool bar.

NOTE: The system setup is
automatically updated each time the 824
Utility is connected to the 824.

The 824 Utility program will bring up a standard windows
save dialog box, where the file name and location of the
setup can be specified.

The System setup can be modified and stored back into the
824, but cannot be saved to a disk file. 

Opening Setup Disk Files

To open a setup disk file select the Open Setup File menu
item from the File menu or click on the Open File button on
the tool bar. 
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A standard windows Open File box will appear. Select the
file folder that contains the file and select the setup file you
want.

The setup appears in the Select Setup list box. You can then
select (highlight) the desired setup in the list. The high-
lighted setup can then be sent to the 824 by selecting the
Save Setup to 824 menu item from the File menu.

Other menu items available in the Setup Menu include
renaming, locking, unlocking, deleting, or making the
selected setup the active setup. 
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Creating a New Setup

You create new setups by selecting the New Setup menu
item from the File menu or by selecting the New Setup but-
ton on the tool bar. 

From the displayed dialog box, select the type of new setup.

Press the OK button and you will now see the new setup in
the Setup List box.
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If a message window occurs after pressing the OK button
like that shown below,

you will have to create a default setup file by following this
procedure:

• Select the permanent setup for the desired instrument
type.

• Under the File menu select “Save setup to a file”.

• In the “Save setup to a file” window type in “default”
under File name and select “Save”.

The new setup is now defined for a particular instrument ID,
and can be modified from the Setup List box. After creating
a new setup, you can store it to a disk file, or send it to the
824.

Renaming an Existing Setup

To rename an existing user defined setup, right click on the
setup in the left hand side of the screen and select Rename
Setup from the popup menu. 
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A dialog box will be displayed to allow you to change the
name of the selected setup.

Enter the new name for the setup, and press the OK button. 

NOTE: The permanent setup ID’s in the
824 cannot be renamed.

After renaming a setup, you can store it to a disk file, or send
it to the 824.

Deleting an Existing Setup

To delete an existing setup, right click on the user defined
setup in the left hand side of the screen and select Delete
Setup from the popup menu.

NOTE: This section applies only to
setups that exist on the 824. If a new
setup or a setup that is stored to disk is
deleted, this message will not appear.

Pressing the Delete Setup button will bring up a prompt ask-
ing if you are sure you want to delete the setup.

WARNING! The setup will be deleted from the 824 and the Utility pro-
gram.
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Locking and Unlocking Setups

To prevent accidently deleting a user defined setup, right
click on the desired setup and select Lock Setup from the
popup menu. Note that if you have just created a new setup,
the setup must first be stored to the 824 before it can be
locked. 

Downloading Measurement Data

To display measurement data stored in the 824, select Down-
load View from the View menu or hit the Download View
button from the tool bar. 

All stored measurement information is retrieved from the
824 and displayed in the Download View window.

Pull down menu

First entry in list
shows the active
measurement

Measurement list
box
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Above the measurement list box is a pull down menu listing
the possible file types that can be displayed. This allows you
to select only the files you want for download. You can also
select “ALL <binary>” which will download all the files in
the 824 simultaneously for translation at a later date. If you
are selecting a specific file type such as “SSA” the measure-
ment list box will show only SSA files.

The first entry in the Measurement list box displays informa-
tion about the active measurement currently in the 824. Fol-
lowing the active measurement is a list of all other Data
Files stored in the 824.

The measurements are identified the same way the setups
were identified in the Setup List Box in the setup portion of
the 824 Utility manual.

Specifying a Destination File

You can tell the 824 Utility program where you want the
downloaded measurements to be stored. From the Download

The three letter Larson Davis assigned name is
listed in the blue Ovals. This indicates the type of
instrument ID for which the setup was created.

The name of the ID is listed in the right hand col-
umn. For the permanent ID’s, this will be the Larson
Davis instrument type. For a user defined ID, this
can be anything that the user defines.

The file number as stored in the 824.
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window, press the File folder button, next to the Directory
entry.

NOTE: The 824 Utility program will
download the files with the date the file
was created as the file name as a default.
It will also download the file to the 824
Utility Folder as a default. The option to
specify a file name and destination folder
is an optional selection, and is not
necessary for download.

A standard Windows file selection dialog box will appear.
Select the destination directory you wish.
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Changing the Download File Name

To change the name of the downloaded file, enter a new
name in the “File name” area.

Press the Save button to return to the download section of
the 824 Utility software.

Our new file name and 
the path to the 
specified directory 
now show on the 
download screen. 
These settings will 
only apply for the 
currently selected 
measurement. 

NOTE: This process will
have to be repeated for
each measurement to be
downloaded if you wish
to specify a file name and
destination folder for
each measurement. For
multiple file download,
each measurement will
use the file name as its
base name. For example,
if the file name is
“Roadtest” then the
download file will be
named “Roadtest-
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Adding Notes to  a download file

Information can be entered into the note fields provided for
each measurement. The information will be tagged onto the
translated reports for each measurements.

Selecting Active Measure ments or Data Files

There are two types of measurements that can be down-
loaded. The first measurement in the list is the Active mea-
surement, and is reported as Active Measurement on the tab
of the download windows. The other measurements are
stored as Data Files (on the 824), and will be reported as
such on the tab of the download window.

Active Measurement

Data file
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Downloading the Measurement

The 824 Utility software has
multiple file download capability by
selecting “ALL <binary>” from the
pull down menu and highlighting
one or more of the files from the
measurement list for download or
selecting files of one type and
highlighting one or more of the files
from the list.

To download a measurement, first select the file type from
the pull down menu. You may choose to view all of them
simultaneously by selecting “ALL <binary>” or you can
select the file type from the list. If you selected “ALL
<binary>”, highlight one or more of the files in the measure-
ment list box and click the Download button. All the
selected files will be downloaded in their binary form.

To get back to the setup screen press
the “setup” button on the toolbar.

If you selected files of the types (SSA, ISM, LOG, TAL,
FFT, or RTA) only this file type will be listed in the mea-
surement list box. Select one or more of the files and click
the Download button. The following window will appear:

Pull down menu

Measurement list
box
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The download window gives you the following options:

• You can save only the binary data and translate the file
later, or

• You can save the binary data and the selected records
from the translated file (saved as .csv or .txt), launch a
spreadsheet or text editor, or

• You can save only the selected records from the trans-
lated file (saved as .csv or .txt) and launch a spreadsheet
or text editor.

Once you have selected the data viewing options, click on
the OK button to start the download process.

Checking this box saves the
binary file in the 824 Utility
directory or the designated
directory.

Checking this box will launch
a program associated with
a.csv file or .txt file based on
the radio box selection. For
multiple file download, the
first file will be loaded into the
viewing program.

Allows selection of only the
records you are interested in
viewing.
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The download status window will appear and report the sta-
tus of the download.

The next file can now be selected, the destination folder
specified, the file name entered, and the data downloaded.

A downloaded file will be stored with
the file extension slmdl (Sound Level
Meter Down-load). 

If you only selected “Save Binary Data” the downloaded file
must be translated by the 824 utility software to be viewable.

The first file in the measurement list
will be viewable in the spreadsheet
or text program. To view the other
records, they will have to be selected
and opened in the viewer program
from the directory where they are
stored.

If you selected “Save Binary Data” and “Launch Viewer of
Type” the Binary file will be saved and a spreadsheet pro-
gram or text file program will automatically be opened.

If you selected only “Launch Viewer of Type”, the Binary
file will not be saved and a spreadsheet program or text file
program will automatically be opened.

Explanation of files in the 824 Utility Directory

In the 824 Utility directory (C:\ProgramFiles\LarsonDa-
vis\824 Utility) you will notice 3 different types of files:

• .slmdl (binary)

• .csv (spreadsheet file)

• .txt (text file)
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The binary files for each virtual instrument (ISM, SSA,
LOG, RTA, FFT, AUD, TAL) have the following default file
designations:

The default file name uses the date
on which the data was taken. The file
name can be changed to any name
that you choose.

• 28Jun15i.slmdl (ISM)

• 28Jun15s.slmdl (SSA)

• 28Jun15l.slmdl (LOG)

• 28Jun15r.slmdl (RTA)

• 28Jun15f.slmdl (FFT)

• 28Jun15a.slmdl (AUD)

• 28Jun15t.slmdl (TAL)

The translated files will have either a .csv extension or a .txt
extension depending on the choice made in the download
window.

Translating Data from a Downloaded Binary File

Selecting “Translate View” from the View Menu or pressing
the Translate button on the tool bar will display the Transla-
tion View. 

28Jun15i.slmd

Designates which instrument type was used for
the measurement.
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You use the Translate view to select a downloaded file with
the file extension.slmdl to translate and view the desired
records from the file on the screen, or to print the desired
records from the file. 

The left portion of the Translate window functions as a Win-
dows file tree. Select the folder that contains the down-
loaded measurement files that you wish to translate.

Locate the folder that contains the
downloaded file you wish to translate.
In this case we have found the down-
loaded file in the default location,
C:\Program Files\Larson Davis\824
Utility.



9/29/09 Using the 824 Utility Software 10-27

Each downloaded file will contain several records, depend-
ing on the type of setup used, and the data stored.

Selecting a Data  set to view

After the downloaded file is located, click on the data you
wish to view.

Downloaded 
measurement file.

Data translated from the 
Downloaded file.
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The data is displayed on the right side of the screen. If the
data record is too large to be effectively displayed in that
area, a message will appear at the top of the displayed record
indicating that it is available for export only.



9/29/09 Using the 824 Utility Software 10-29

Printing a Translated File 

To print the translated data, select the file that you wish to
print from the translate window . Display the file as
described earlier. Select Print from the File menu.
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The default Windows printer dialog box will be displayed.
The report will be printed in a text format similar to that
shown below.
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Viewing a Translated File Within a Spreadsheet Program

To view the translated data with a spreadsheet program,
select the View Data in Spreadsheet menu item from the
File menu or the Launch Spreadsheet button on the tool bar. 

When you select the View Data in Spreadsheet menu item,
the 824 utility program will attempt to launch the program
associated with the .csv” file extension (comma separated
variables). If you have installed a spreadsheet program, your
Windows system will most likely have this file type linked
to that spreadsheet program. 
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Once the data is in the spread sheet program it can be manip-
ulated, stored, and graphed using the standard spreadsheet
functions.

You can also export and/or save the translated data to a text
file, by selecting the Export Data menu item from the File
menu.

Additional Features

Store Histograms for Overall and Interval Data

One of the features of the 824 Utility software is the ability
to store histograms in both the LOG and SSA virtual instru-
ments for overall, interval, and daily data (LOG only). 

These settings can only be made
from the 824 Utility software.

To store an interval histogram for the SSA instrument, select
SLM&RTA from the measurement list, click on the “Interval
tab” and check the box by “Store complete Histogram”.

NOTE: Storing interval or daily histograms for the LOG
instrument is done in a similar manner.
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Histogram Options Window

These settings only affect how the
data is displayed and not how they
are stored.

The histogram options window allows more flexibility in
viewing the histograms.

Here you can set the parameters to fit your particular needs.
To access the histogram options window, go under the
“View” menu item and select “Histogram Options”.

When viewing the histogram data,
the changes made in this window
will be immediately displayed.

The “Overall” area allows you to set the viewing parameters
for the overall SPL, Peak, and Unweighted Peak histograms.

The daily data is only available to
the LOG instrument.

The “Interval/Daily” column sets the parameters for display-
ing the SPL histogram for the interval period for either the
SSA or LOG instruments and also for the daily period data
for the LOG instrument.

NOTE: Storing the complete histogram for each interval and
daily record greatly reduces the number of events that can be
stored.
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RT60 Select Options

The 824 Utility software can calculate an RT60 for each 1/3
octave frequency from the autostore ByTime data taken by
the RTA instrument. 

The software gives you the flexibility to set the options for
the calculation and display of the RT60 values.

You must first take an autostore ByTime measurement.
Download the measurement and go to the Translate view
and select an RT60 report.

To change the RT60 calculated and displayed parameters, go
under the “View” menu item and select “Set RT60 Options”.
The following window will appear:

Single click on a valid
RT60 report.
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RT60 Measurements

Both the 824 instrument and the 824 Utility software round
the RT60 values to two decimal places. However, because
the 824 uses logarithmic arithmetic to calculate the RT60
value and the 824 Utility software uses double precision to
calculate the value, there may be small differences in the
values as reported by the 824 instrument and by the 824
Utility software.
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